MTD data did not update last night for Shopify users.

Incident Report for Retail Orbit LLC.

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 06:15 MST

Investigating

MTD data did not update last night for Shopify users. We are looking into the issue and will provide an update as soon as possible. Apologies for the interruption in service,

Thank you for using Retail Orbit
Posted Mar 18, 2025 - 07:40 MST
This incident affected: Reports (Month To Date Reports) and Shuttle Flights.