Retail Orbit reporting is currently reflecting data as of June 16th.

Incident Report for Retail Orbit LLC.

Resolved

All Retail Orbit reporting is now up to date.
Posted Jun 18, 2026 - 07:48 MST

Identified

Retail Orbit reporting is currently reflecting data through June 16th.

The issue has been identified, and the team is actively working on a resolution. Reporting is expected to be fully current by 8:00 AM PST.

We apologize for any inconvenience and appreciate your patience while we complete the update.
Posted Jun 18, 2026 - 07:27 MST
This incident affected: Reports (Month To Date Reports).